Mi6WAN Client Config

An antenna MUST be connected to the radio at all times when it is powered on.
Not having an antenna connected will result in damage to the radio!!!
These instructions are a work in progress

Preface

This describes one simple method of configuring your radio modem to connect to Mi6WAN. It will configure your radio to be used connected directly to a computer(s) without another internet connection. It will provide a provide DHCP address to computers connected over ethernet and will have a public 44.x.x.x address on the wireless side.

Understanding What Mi6WAN Is and Isn’t

  • Who can use it?
    • Anyone with a valid Amateur Radio license can use our network
  • What can it be used for?
    • Primarily the network is intended to serve as an emergency communications system
    • Encrypted Traffic is not allowed
    • Commercial traffic is prohibited

Integration With An Existing Network

Integrating Mi6WAN with an existing network is not a simple task an involves complex networking concepts and may be beyond the capabilities of your home networking equipment.

Configuration Steps

These steps should get you on the air but do not include any local networking (radio will have Mi6WAN access but your computer will not)

    1. Upgrade your modem to the latest version of RouterOS
      • If you have connected the modem to your LAN in a way that provides Internet access, the following command can be used:
        /system package update upgrade
      • Otherwise, use the standalone upgrade method: http://wiki.mikrotik.com/wiki/Manual:Upgrading_RouterOS (also works on older ROS 5.xx that does not support the upgrade command)
    2. Reset the router to a blank configuration.
      /system reset-configuration no-defaults=yes
    3. Give your modem a name, use your callsign so that we can easily identify the owner of this radio
      /system identity set name=MYCALL/MYLOCATION
    4. Set a password for the admin user
      /user set admin password=
      /console clear-history

      This is an example password generated in your browser. You may choose any password you like.

    5. To support shared administration, add the following Mi6WAN Network Administration accounts into the “full” group. Usernames are case sensitive.  Send this to noc@w8cmn.net when created and online.
      /user add group=full name=w8cmn password=
      /console clear-history

      The passwords above are randomly generated in your browser, not stored anywhere.

    6. Enable Ethernet boot in case you ever need to reinstall the router with NetInstall (this could save you a trip up to your roof, its a good idea)
      /system routerboard settings set boot-device=try-ethernet-once-then-nand
    7. Configure Remote Central Logging
      /system logging action set 3 bsd-syslog=no name=remote remote=44.103.0.13 remote-port=514 src-address=0.0.0.0 syslog-facility=daemon syslog-severity=auto target=remote
      /system logging add action=remote disabled=no prefix="" topics=info
      /system logging add action=remote disabled=no prefix="" topics=warning
      /system logging add action=remote disabled=no prefix="" topics=error
      
    8. SNMP Monitoring
      /snmp set enabled=yes contact="CALLSIGN Location EMAIL ADDRESS"
      /snmp community set name=mi6public addresses=44.103.0.0/16 read-access=yes write-access=no numbers=0 trap-version=2
    9. Clear the firewall rules
      /ip firewall filter remove [find dynamic=no]
      

 

  1. Remove local DHCP server
    /ip dhcp-server remove [find]
    /ip dhcp-server network remove [find]
    
  2. Remove local IP address
    /ip address remove [find]
  3. Disable DNS Service Important!!!
    /ip dns set allow-remote-requests=no
  4. Add Mi6WAN sector channels. Mi6WAN uses custom channels outside the normal frequency range for 5ghz and 2ghz WiFi, you need to add these channels to the radio. Currently all of our sector sites use 10mhz channels but you should add both 5 and 10 variants to be safe.  Add only the band channels for the radio you are using 2.4ghz or 5.9ghz.
    /interface wireless channels add band=5ghz-onlyn frequency=5920 list=Mi6WAN5.9 name=Sector1-5 width=5
    /interface wireless channels add band=5ghz-onlyn frequency=5900 list=Mi6WAN5.9 name=Sector2-5 width=5
    /interface wireless channels add band=5ghz-onlyn frequency=5880 list=Mi6WAN5.9 name=Sector3-5 width=5
    /interface wireless channels add band=5ghz-onlyn frequency=5920 list=Mi6WAN5.9 name=Sector1-10 width=10
    /interface wireless channels add band=5ghz-onlyn frequency=5900 list=Mi6WAN5.9 name=Sector2-10 width=10
    /interface wireless channels add band=5ghz-onlyn frequency=5880 list=Mi6WAN5.9 name=Sector3-10 width=10
    
    /interface wireless channels add band=2ghz-b/g/n frequency=2397 list=Mi6WAN2.4 name=Channel-2-10 width=10
    /interface wireless channels add band=2ghz-b/g/n frequency=2402 list=Mi6WAN2.4 name=Channel-1-5 width=5
    /interface wireless channels add band=2ghz-b/g/n frequency=2397 list=Mi6WAN2.4 name=Channel-2-5 width=5
    /interface wireless channels add band=2ghz-b/g/n frequency=2402 list=Mi6WAN2.4 name=Channel-1-10 width=10
    
  5. Configure the modem to announce your callsign
    /interface wireless set 0 radio-name="MYCALL"
    
  6. Configure the wireless card to connect to Mi6WAN one string is 5.9ghz the other 2.4ghz clients
    /interface wireless set 0 disabled=no frequency-mode=superchannel band=5ghz-onlyn mode=station-wds scan-list="Mi6WAN5.9" ssid=Mi6WAN wireless-protocol=nv2
    
    or
    
    /interface wireless set 0 disabled=no frequency-mode=superchannel band=2ghz-b/g/n mode=station-wds scan-list="Mi6WAN2.4" ssid=Mi6WAN wireless-protocol=nv2
    
    
  7. Configure your modem to request a DHCP address from the HamWAN network.
    /ip dhcp-client add add-default-route=yes dhcp-options=hostname,clientid disabled=no interface=wlan1
    

Next Steps

Integrating Mi6WAN into your LAN

There are a number of ways to integrate Mi6WAN into your local network – dedicated local network for Mi6WAN use. We will discuss only the simplest here for now. PDSR has an in depth article describing other methods here.

 

Create an isolated LAN for use with Mi6WAN

Remember to ensure you are within the restrictions of your license it is important to fully understand your network implementation and how traffic will move through it. In this simple configuration all WAN bound traffic will be transmitted/received over your Mi6WAN radio.

  1. Assign an IP address to your modem’s LAN port
    /ip address add address=192.168.88.1/24 interface=ether1
    
  2. Configure DHCP server
    /ip pool add name=dhcp-pool ranges=192.168.88.100-192.168.88.199
    /ip dhcp-server network add address=192.168.88.0/24 dns-server=44.103.0.4,44.103.1.4 gateway=192.168.88.1
    /ip dhcp-server add address-pool=dhcp-pool interface=ether1 name=dhcp disabled=no
    
  3. Configure NAT (Network Address Translation)
    /ip firewall nat add chain=srcnat action=masquerade out-interface=wlan1
    
  4. Connect one end of an Ethernet cable to your modem and the other to the PoE injector (the injector included with the Metal feeds power to the socket side of the adapter). Plug the injector directly into your PC, or into a switch for use with multiple PCs. The modem will assign IP addresses to connected PCs and route their packets to Mi6WAN.